+1 Daumen
263 Aufrufe

Es ist ein Netzverkehr gegeben und es soll erläutert werden, warum der Verbindungstest nicht erfolgreich war.

Hier zunächst die Tabelle für die IP-Adressen/Netzadressen der PCs in der gesamten Netzstruktur sowie die Adressen der Router:


IP-AdresseNetzadresseSubnetzmaske
PC1192.168.151.111192.168.151.0255.255.255.128
PC2192.168.151.212192.168.151.192255.255.255.192
PC3
192.168.151.145192.168.151.144255.255.255.252
PC4
192.168.151.149192.168.151.148255.255.255.252
PC5
192.168.151.155192.168.151.152255.255.255.248
PC6
192.168.151.166192.168.151.160255.255.255.240
PC7
192.168.151.177192.168.151.177255.255.255.255



MACIP
R1B
02:13192.168.151.1
R2A
01:15192.168.151.126
R2B
02:15192.168.151.254
R3A
02:14192.168.151.193

R1 und R3 verwenden also die ersten verfügbaren, R2 die letzten verfügbaren IP-Adressen im jeweiligen Subnetz.

Außerdem wurden die Subnetze von PC3, PC4, PC5 und PC6 zu einem CIDR-Netz (mit der Netzadresse 192.168.151.144/28) zusammengefasst.

Die restlichen Infos samt Netzstruktur habe ich unten in einem Bild zusammengefasst:

Fehlersuche.PNG

Mir ist nun nicht ganz klar, weshalb das ICMP-Request in die falsche Richtung geht (R3A), es müsste ja eigentlich an R2B gehen. In der Routing-Tabelle sehe ich, dass als Ziel u. a. 192.168.151.128 eingetragen ist. Ich vermute, das ist ein weiteres Subnetz von PC2 oder? Die Default-Route wäre hier ja die einzig sinnvolle, aber die wird ja immer erst sozusagen als letztes Mittel genommen. Für PC2 scheint also das andere Subnetz richtig zu sein. Da für dieses als Gateway die IP-Adresse von R3A eingetragen ist, würde das natürlich auch erklären, weshalb es in die falsche Richtung geht. Aber wie gesagt bin ich mir nicht sicher.

Des Weiteren hat man uns einen Tipp gegeben, dass in der Routing-Tabelle für Router 3 die PCs 3-6 als zusammengefasstes CIDR-Netz hätten eingetragen werden müssen und nicht einzeln. Aber was wäre dann anders gewesen? Der Router 3 hätte die ARP-Anfrage (Who has .177 (PC7)) dann ebenfalls nur in das CIDR-Netz von PC3-6 geschickt, oder?

Vor allem ist in der Routing-Tabelle von Router 3 ja auch zu sehen, dass die Default-Route mit Gateway .254 (was der Router 2 ist) eingetragen ist. Warum wurde die ARP-Anfrage an PC7 also nicht über diese Default-Route geschickt? Dann wäre das Paket an Router 2 geschickt worden, von dort wieder an Router 1 und schließlich an PC7.

Wäre echt hilfreich, wenn mir hier jemand weiterhelfen könnte. Ich habe jetzt hier schon eine halbe Ewigkeit gegrübelt und bin zu keinem wirklichen Ergebnis gekommen.

Vielen Dank im Voraus! :)

von

Ein anderes Problem?

Stell deine Frage

Willkommen bei der Stacklounge! Stell deine Frage sofort und kostenfrei

x
Made by a lovely community